Register    Login    Forum    Search    FAQ Awesomenauts



Post new topic Reply to topic Go to page Previous  1 ... 9, 10, 11, 12, 13  Next

Author Message
 Post subject: Re: Ask various map editor questions here
 Post Posted: Sun Jul 02, 2017 1:54 pm 
Offline
User avatar

Joined: Wed Oct 15, 2014 8:43 pm
Posts: 709
To add to what Blatoy said, the depth of turrets, bouncers, procedural level art, and the like cannot be changed. The only thing you can affect are the textures. The depth buttons don't work for me either. They might be broken or designed in a really shortsighted way, but I don't use them.

The two things you need to worry about are parallax and depth. The two are similar, but parallax is always what you look at first. When two textures have the same parallax you would use depth to fine-tune them.

Image

Parallax and depth are structured the same way: the greater the value, the further away the object appears. The lower the value, the closer the object appears. All objects like turrets have a predesignated value for their parallax & depth, all you need to do is simply tweak your texture's values until it moves where you want it. It's that easy!

A few tips: The player character is always on parallax 0. Objects get automatically blurred when they reach a certain parallax, and you can change this threshold from the settings menu (the gear).


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Sun Jul 09, 2017 4:05 pm 
Offline

Joined: Thu May 04, 2017 8:35 am
Posts: 8
Hey, I can't seem to save any parallax > 0 textures.

Everytime I leave the editor they disappear... even when I just add one, save and immediately reopen the editor or go in to a game it's gone. Nothing is obstructing it, I have not disabled the layer and I'm loading the map that should have the texture but nothings showing up. Anyone else ran into this problem? I've confirmed in the editor that they are properly gone but I can't figure out how to resolve this issue.


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Sun Jul 09, 2017 5:05 pm 
Offline
User avatar

Joined: Mon Jun 15, 2015 11:27 am
Posts: 90
Location: Switzerland
FearJudge wrote:
Hey, I can't seem to save any parallax > 0 textures.

Everytime I leave the editor they disappear... even when I just add one, save and immediately reopen the editor or go in to a game it's gone. Nothing is obstructing it, I have not disabled the layer and I'm loading the map that should have the texture but nothings showing up. Anyone else ran into this problem? I've confirmed in the editor that they are properly gone but I can't figure out how to resolve this issue.


What value did you set for the parallax? When it's not between 1 and - 1 they move really fast even in the editor so they may just lie somewhere really far away.

If the value was between 1 and -1 did you try to create a new map to see if you have the same problem?

_________________
Tools:
NautsBuilder V2
NautsRankings V2
Replay finder

More tools here!

:tongue: :party:


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Sun Jul 09, 2017 6:42 pm 
Offline
User avatar

Joined: Wed Oct 15, 2014 8:43 pm
Posts: 709
FearJudge wrote:
Hey, I can't seem to save any parallax > 0 textures.

Everytime I leave the editor they disappear... even when I just add one, save and immediately reopen the editor or go in to a game it's gone. Nothing is obstructing it, I have not disabled the layer and I'm loading the map that should have the texture but nothings showing up. Anyone else ran into this problem? I've confirmed in the editor that they are properly gone but I can't figure out how to resolve this issue.

Can you take a screenshot of texture in the editor so we can see the settings?


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Sun Jul 09, 2017 7:47 pm 
Offline

Joined: Thu May 04, 2017 8:35 am
Posts: 8
Here's a link to an imgur post with an explanation on my problem.

http://imgur.com/a/026j8

I know that the parallax goes fast with high values and such, but I'd like to point out that negative parallaxes (closer to the screen) DO seem to save normally. For instance my droppod section has a foreground sand layer at parallax - 0.1 and it's been there for multiple exits already. Yet none of my background > 0 parallaxes have ever stayed in this map. Even when I've done other work on the map at the same time, everything else stays except the negative parallaxes. They also appear on the in-editor test but as soon as I quit, that's it, they are gone.

EDIT: I forgot to mention, but it seems that copy and pasting said positive parallaxes also produces unaccessible textures where I can even verify with coordinates where the item should be and that all settings are fine, yet nothing appears and releasing the hold on it immediately makes it impossible to access. Same happens also if you try to copy the textures with the tool "copy selection around the centre of the map".

EDIT2: I'm not very good with imgur so if the link is somehow flawed or leads to the editable version, please let me know.

EDIT3: I missed one of your questions Blatoy, sorry. Yes, this does seem to happen even in a brand new map. (template arena, with just that texture added in)


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Mon Jul 10, 2017 11:53 am 
Offline
User avatar

Joined: Mon Jun 15, 2015 11:27 am
Posts: 90
Location: Switzerland
Hmmm I don't see anything strange. Could you create an empty map, place the texture with the parallax, reload to make it disappear and then send me the map? (or publish it on the workshop and give me the link)

_________________
Tools:
NautsBuilder V2
NautsRankings V2
Replay finder

More tools here!

:tongue: :party:


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Mon Jul 10, 2017 9:12 pm 
Offline

Joined: Thu May 04, 2017 8:35 am
Posts: 8
Hey, thanks for sticking with me and sorry for the late responses.

Here's a map I created to hopefully verify this issue I'm having.
http://steamcommunity.com/sharedfiles/f ... =972692527

(
For link-phobic people you can also use the following steps to reach this item:
- Open Steam
- Go to Community -> Home
- In Search for people, type: "FearJudge" (without quotes)
- Click on my name (should be the only one, my avatar is mostly black and gray)
- Go to Workshop Items in my profile
- Choose "ParallaxIssue (NOT PLAYABLE)" (again, without quotes)
)

I have also now verified integrity of Awesomenauts through steam, it followed up with a small update and the first time setup was redone so I was semi-hopeful that would fix it, but alas as far as I can tell this is not the case.
These textures should also be present in "The Core" (my other public submission) as it's the reason I found out about this issue I'm having.

I will also add, before anyone asks, that I have been able to save positive parallaxes before, I did so on numerous occasions on my first map (which I lost to carelessness, by deleting the test mod with the map still inside) and never did they disaapear like so, I can't say for sure then when this started occuring but at least the first 2 public level-editor updates I have been able to save positive parallaxes.


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Mon Jul 10, 2017 10:00 pm 
Offline
User avatar

Joined: Mon Jun 15, 2015 11:27 am
Posts: 90
Location: Switzerland
FearJudge wrote:
Hey, thanks for sticking with me and sorry for the late responses.

Here's a map I created to hopefully verify this issue I'm having.
http://steamcommunity.com/sharedfiles/f ... =972692527

...


So I just downloaded the mod and I can see all the textures even after saving and reloading...
Did you try it in the beta? Are you on linux/mac?

_________________
Tools:
NautsBuilder V2
NautsRankings V2
Replay finder

More tools here!

:tongue: :party:


Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Tue Jul 11, 2017 12:11 am 
Offline

Joined: Thu May 04, 2017 8:35 am
Posts: 8
I am running Awesomenauts on the non-beta Windows version with Windows 10.

I will try the beta when I get around to downloading the whole thing again. (takes a while and I've been sort of distracted by another "game" recently too.)
That's strange, so it seems it's a me problem then which makes it an issue of me not seeing parallaxes appearantly, or rather, me not being able to interract with them even in editor.
I can see the normal map parallaxes just fine so I wonder what's the issue.

I'll try the following before I'll get back to complaining if they don't work:
- Download the beta and see if the problem persists.
EDIT1: Downloading the beta seems to have resolved the issue at least for now, I will also report back on the other points as I get to them in a later date. Thanks for the help.
- > As a follow up, if it works I will download the normal client again to see if there's some mysterious bug there.
EDIT2: Issue persisted.
- Reinstall the game and see if the problem persists.
EDIT2: This fixed the issue, but I forgot to backup my mod... Thankfully I did at least backup the map so I was not completely screwed.


All of this probably takes a while so I'll get back to you all with either an edit or new post after I get some result or go through all the notions.

P.S. Sorry for raiding the question forum like this, I should've made a new thread for my issue.


Last edited by FearJudge on Tue Jul 18, 2017 8:47 pm, edited 1 time in total.

Top 
 Profile  
 
 Post subject: Re: Ask various map editor questions here
 Post Posted: Tue Jul 11, 2017 7:56 pm 
Offline
User avatar

Joined: Wed Oct 15, 2014 8:43 pm
Posts: 709
FearJudge wrote:
EDIT1: Downloading the beta seems to have resolved the issue at least for now, I will also report back on the other points as I get to them in a later date. Thanks for the help.

That's odd, I wonder what went wrong. Normally, if nothing worked, you would have to send your logs to ronimo for them to look at. This might be a bug that still exists for other users too, but not everyone uses the map editor so they might never know about it. Also, no worries, this topic was the right place to post your issue.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic Go to page Previous  1 ... 9, 10, 11, 12, 13  Next