Register    Login    Forum    Search    FAQ Awesomenauts

Post new topic Reply to topic

Author Message
 Post subject: Xbox One bot match - third controller cannot join
 Post Posted: Thu Apr 27, 2017 3:56 am 

Joined: Thu Apr 27, 2017 3:15 am
Posts: 2
I did a search through the Internet and this forum to no avail hence this topic. If this has been covered already then my apologies and please point me to the right direction.

Purchased this game on Xbox One S (500MB) through Microsoft Store and played 3v3 bot matches locally using three official Microsoft Xbox One S controllers. It was all good and fun.

Recently had one of the controllers replaced under warranty and that's when this problem started: no matter how hard I tried the game only allows TWO players to join and ignore the third (not a particular unit, just depends on the connecting order) controller at the setup screen of bot matches. So far I have tried and found:

  • Xbox One S and all controllers are on the latest firmware.
  • Awesomenauts Assemble is on the latest build (sorry, don't have the version here). No updates found. I even tried to re-install it after wiping it clean (see below).
  • Xbox One S is nowhere near its full storage capacity so it's not running out of space.
  • All three controllers are connected to Xbox One S and assigned to correct player profiles.
  • No other multi-players games have any issues with three controllers/players locally on the same Xbox One S. For examples: FIFA 2017, Overcooked etc.
  • Switching controllers on/off proves that all three controllers are recognised by the game but only TWO can work at a time???
  • Switching profiles and/or guest account makes no differences.
  • Deleted all game progress local/online and re-installed the game fresh to no avail. Any profile saved on the Xbox can start the game and then one more controller can join and that's it. Whoever come to the party too late is kept outside.
  • Deleted Xbox One S cache by completely powering off the device and then disconnect the power cord for a minute to no avail.

To sum up how to replicate the issue again:

    1. Connect all three controllers #1, #2 and #3 to Xbox.
    1. Start the game using ANY controller/profile, let's say #3 - all good.
    2. Select 'Bot Match' at main menu.
    4. Game only respond to #1. #2 is ignored.
    5. Switching off controller #1.
    6. Instantly the game is responding to #2.

It almost sounds to me that the game is thinking that I have more than three controllers and always ignoring the third thinking it's the fourth or something like that? I'm 200% that I don't have a fourth active Xbox controller or any other Xbox devices (remote/kinect etc) in the house. The Xbox devices screen only shows three active controllers and it used to work fine before replacing the controller.

From all the tests I have performed above it points to the game rather than Xbox/Controllers.

The last thing that I yet to try is to hard reset the Xbox One S and reinstall everything from scratch but I really don't want to do that because a single game is having a weird issue while all others are fine.

I'd like hear some suggestions on fixing this issue. If you need more information from me please just ask. Thanks in advance.

 Post subject: Re: Xbox One bot match - third controller cannot join
 Post Posted: Sun Apr 30, 2017 11:30 pm 

Joined: Thu Apr 27, 2017 3:15 am
Posts: 2
For anyone who might be interested: I finally decided to hard reset my Xbox One S and re-installed everything from scratch. Unfortunately the problem still persists.

So there's something about the controllers I have that are conflicting or the Xbox BIOS is confused. However, I still cannot shake off the annoyance that the game should handle this for every other multi-player game I have has no issues with this, only Awesomenauts.

Display posts from previous:  Sort by  
Post new topic Reply to topic