Register    Login    Forum    Search    FAQ Awesomenauts



Post new topic Reply to topic Go to page 1, 2, 3  Next

Author Message
 Post subject: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 8:21 am 
Offline
User avatar

Joined: Fri Jun 24, 2011 8:17 am
Posts: 3
I've noticed several people who are having a black screen and then a crash when the game starts. I'm having a couple different problems, also on Windows 7 64 bit.

For starters, on install, I get a loop of these: http://i.imgur.com/43YTL.png
The installer keeps getting to that point, then it has a problem and starts over until I cancel it, at which point it looks as though it's installed.

After a fresh install, when I try to run the game, I get this error:
Quote:
The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.


I've been excited to play this game for a while, so I can't wait to see a fix for these problems.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 10:08 am 
Offline
Ronimo Team Member
User avatar

Joined: Thu Apr 23, 2009 5:45 pm
Posts: 8990
Argh, I don't understand why the installer for Microsoft's DLL's does that. :( At least the game is fully installed when it gets there. Could you try running this one separately?

Proun\VCRedist\vcredist_x86.exe

It is specifically there to fix the "side-by-side configuration" error you are getting.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 3:16 pm 
Offline

Joined: Fri Jun 24, 2011 3:03 pm
Posts: 1
Hi i have similar problem to this, but i dont get a loop, for me the redistribute thingy doesnt accept its own vcredist.msi, so it wont install, and also im pretty sure i have that already.
When i try to launch the game it gives me the side-bye-side config error.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 5:07 pm 
Offline

Joined: Fri Jun 24, 2011 4:58 pm
Posts: 1
I'm also getting an error when I try to load up the game. After I install the game and run the game, the screen comes up black and the mouse icon appears. The black screen goes away if I hit enter or space and quits me out of the game.

Any idea what could be causing this?


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 7:18 pm 
Offline
User avatar

Joined: Fri Jun 24, 2011 8:17 am
Posts: 3
Joost wrote:
Argh, I don't understand why the installer for Microsoft's DLL's does that. :( At least the game is fully installed when it gets there. Could you try running this one separately?

Proun\VCRedist\vcredist_x86.exe

It is specifically there to fix the "side-by-side configuration" error you are getting.



When I do that, I get the same error I'm getting on instal when that runs (which also freezes my machine for a good minute every time):

Quote:
Error 1935.An error occurred during the installation of assembly "Microsoft.VC80.ATL,type="win32",version="8.0.50727.6196".publicKeyToken="1fc8b3b9a1e18e3b".processorArchitecture="x86"'. Please refer to Help and Support for more information.


After running it on its own, I get the same error on launch as I did before.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 7:36 pm 
Offline

Joined: Fri Jun 24, 2011 7:32 pm
Posts: 1
I'm dying to play this game and I get the exact same error! I managed to find one of the .msi'd in
Code:
C:\OEM\Preload\Autorun\DRV\AMD VGA Chip UMA\Packages\Apps


But no matter where I put it, it keeps telling me to find the .msi in a place where it can install Visual 2005 C++ redistrribution


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 7:38 pm 
Offline
Ronimo Team Member
User avatar

Joined: Thu Apr 23, 2009 5:45 pm
Posts: 8990
Hmm, nasty, I don't know yet what is causing this. :(

I see Microsoft has released a newer version of vcredist, could you try downloading and running that? You can download it here:

vcredist_x86.exe

Does that give the same result?


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 8:48 pm 
Offline
User avatar

Joined: Fri Jun 24, 2011 8:17 am
Posts: 3
This new exe runs fine, but the game still doesn't run. I get the same error.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 9:18 pm 
Offline

Joined: Fri Jun 24, 2011 9:13 pm
Posts: 4
Joost wrote:
Hmm, nasty, I don't know yet what is causing this. :(

I see Microsoft has released a newer version of vcredist, could you try downloading and running that? You can download it here:

vcredist_x86.exe

Does that give the same result?



By the way why did you not just include the DLL files in the game's folder like everybody else does it, I hate it when game installers launch the installation of some DirectX or other redistributable stuff automatically.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Fri Jun 24, 2011 9:34 pm 
Offline

Joined: Fri Jun 24, 2011 9:24 pm
Posts: 3
Windows 7 64bit user here as well. I was getting the same error:

Quote:
The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.


I did some digging around. The Windows event log tells me:

Quote:
Activation context generation failed for "C:\Games\Proun\Proun.exe". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.6195" could not be found. Please use sxstrace.exe for detailed diagnosis.


I also took a look at your assembly information in your executable. It appears I need:

Quote:
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0"><dependency><dependentAssembly>
<assemblyIdentity type="win32" name="Microsoft.VC80.CRT" version="8.0.50727.6195" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b" />
</dependentAssembly></dependency><dependency><dependentAssembly>
<assemblyIdentity type="win32" name="Microsoft.VC80.CRT" version="8.0.50727.762" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b" />
</dependentAssembly></dependency></assembly>


I took a look in C:\Windows\winsxs. Both 8.0.50727.6195 and 8.0.50727.762 are there. They contain the same DLL's. The output of sxstrace.exe looks like this: http://dl.dropbox.com/u/188865/sxstrace.txt (the output is quite large so I haven't included it here).

I don't know why the program has trouble finding the DLL location. Since both dependencies seem to offer the same DLL's, I just hex edited Proun.exe and took out the 8.0.50727.6195 one. After doing this the game works just fine. I don't know the intricacies, but it should probably be possible to remove the 8.0.50727.6195 VC80 redist from your manifest.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic Go to page 1, 2, 3  Next

cron