Register    Login    Forum    Search    FAQ Awesomenauts



Post new topic Reply to topic Go to page Previous  1, 2, 3

Author Message
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Sun Jun 26, 2011 9:33 am 
Offline

Joined: Sun Jun 26, 2011 9:18 am
Posts: 1
Same problem for me on Windows 7 32-bit. After doing some fiddling around, I'm pretty sure the problem is a bad manifest file on the original compile. Using PE Explorer I removed the following lines from the manifest file, and had no problems.

Code:
  <dependency>
    <dependentAssembly>
      <assemblyIdentity type="win32" name="Microsoft.VC80.CRT" version="8.0.50727.6195" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>
    </dependentAssembly>
  </dependency>


As far as I can tell the only reference to depending on this particular version of the VC80 libraries is this part of the manifest file, and execution doesn't seem to be affected at all. I've got SxSTrace logs of the before and after for comparison if needed, too. Changing the manifest file and recompiling or just changing it with PE Explorer the way I did and putting out a new installer should see the end of this problem for good.


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Sun Jun 26, 2011 8:21 pm 
Offline
Ronimo Team Member
User avatar

Joined: Thu Apr 23, 2009 5:45 pm
Posts: 8990
I think I am just going to dare and use the newest vcredist in the installer. Pity I cannot try whether this really works without potentially breaking it for future buyers, but if I put it online tonight I can replace it with the previous version tomorrow if really needed... So this version is going into the installer:

http://www.microsoft.com/download/en/de ... n&id=26347


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Mon Jul 04, 2011 11:32 am 
Offline

Joined: Mon Jul 04, 2011 10:49 am
Posts: 1
Hey Joost, I'm sure you didn't want to see this thread again.
Unfortunately...
I'm also having the side-by-side config error, on Win7 x64, but I'm getting an extra problem with the vcredist installers you've bundled (new and old) - it hangs for a few minutes and then crashes at 99% with this message:
Image
I've tried running the install as administrator, but it doesn't help.
After the install, running a working vcredist doesn't help the problem. Steam insists on reinstalling VC++ with everything I download, and that usually goes fine so I'm not sure what's wrong with this version. I'm not sure what I'm doing editing manifests or doctoring .exes, so I've not tried anything that extreme.
Is it possible to upload a version without the dependency Vertel picked out, AdamDawes' doctored version, or something similar?


Top 
 Profile  
 
 Post subject: Re: Problems with Proun - Windows 7 64 bit
 Post Posted: Wed Jul 06, 2011 1:59 pm 
Offline
Ronimo Team Member
User avatar

Joined: Thu Apr 23, 2009 5:45 pm
Posts: 8990
There is little I can do about Microsoft distributing broken versions of their own installers: it's not like I made vcredist myself. Proun comes with the newest version of that.

So, sorry, but I really don't see any further options to fix this. There is no newer version and older versions don't seem to install well on some Windows 7 versions either.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic Go to page Previous  1, 2, 3

cron